src/{Makefile.am,main.c}: Use the debugging as determined by the configure script.
[routeros-api.git] / src / Makefile.am
index db3f30b..da3dda1 100644 (file)
@@ -2,6 +2,9 @@ AUTOMAKE_OPTIONS = foreign no-dependencies
 
 if COMPILER_IS_GCC
 AM_CFLAGS = -Wall -Werror
+if BUILD_WITH_DEBUG
+AM_CFLAGS += -Wextra -g -O0
+endif
 endif
 
 include_HEADERS = routeros_api.h routeros_version.h