Build system: Fix linking with libheap.la and depend on testing.h.
[collectd.git] / src / daemon / Makefile.am
index 06bc150..7f826e3 100644 (file)
@@ -94,11 +94,11 @@ endif
 check_PROGRAMS = test_common test_utils_avltree test_utils_heap
 TESTS = test_common test_utils_avltree test_utils_heap
 
-test_common_SOURCES = common_test.c
+test_common_SOURCES = common_test.c ../testing.h
 test_common_LDADD = libcommon.la libplugin_mock.la
 
-test_utils_avltree_SOURCES = utils_avltree_test.c
+test_utils_avltree_SOURCES = utils_avltree_test.c ../testing.h
 test_utils_avltree_LDADD = libavltree.la
 
-test_utils_heap_SOURCES = utils_heap_test.c
+test_utils_heap_SOURCES = utils_heap_test.c ../testing.h
 test_utils_heap_LDADD = libheap.la