bindings/Makefile: perl: Use INSTALL_BASE rather than PREFIX.
[collectd.git] / bindings / Makefile.am
index 1a28e29..69312fd 100644 (file)
@@ -4,8 +4,11 @@ if BUILD_WITH_JAVA
 SUBDIRS += java
 endif
 
-EXTRA_DIST = perl/Collectd.pm perl/Makefile.PL \
-               perl/Collectd/Unixsock.pm
+EXTRA_DIST = perl/Makefile.PL \
+            perl/lib/Collectd.pm \
+            perl/lib/Collectd/Unixsock.pm \
+            perl/lib/Collectd/Plugins/Monitorus.pm \
+            perl/lib/Collectd/Plugins/OpenVZ.pm
 
 all-local: @PERL_BINDINGS@
 
@@ -20,14 +23,15 @@ perl: perl/Makefile
 
 perl/Makefile: .perl-directory-stamp perl/Makefile.PL \
        $(top_builddir)/config.status
-       cd perl && @PERL@ Makefile.PL PREFIX=$(prefix) @PERL_BINDINGS_OPTIONS@
+       cd perl && @PERL@ Makefile.PL INSTALL_BASE=$(prefix) @PERL_BINDINGS_OPTIONS@
 
 .perl-directory-stamp:
        if test ! -d perl; then \
-         mkdir -p perl/Collectd; \
+         mkdir -p perl/Collectd/Plugins; \
          cp $(srcdir)/perl/Collectd.pm perl/; \
          cp $(srcdir)/perl/Makefile.PL perl/; \
          cp $(srcdir)/perl/Collectd/Unixsock.pm perl/Collectd/; \
+         cp $(srcdir)/perl/Collectd/Plugins/OpenVZ.pm perl/Collectd/Plugins/; \
        fi
        touch $@